How to update existing database on backfilling in amibroker.

#1
I have amibroker 5.5 when I have Intraday data for suppose NCC script. from 20.3.2015 to 25.3.2015. Now when I backfill the data from external data feeder software (RT) to amibroker from 26.3.2015 to 30.3.2015 . It dont update it , it replace new data from old data. So data from 20 to 25march had been lost. What to do to keep both data in single database or it updates new data without deleting old data?
 

mastermind007

Well-Known Member
#2
Amibroker (in trial mode) will not save data.

If your amibroker is not running in trial mode, you've either kept upper limit too low or something very basic is wrong. Does your machine have enough hard-drive space?

Check Tools->Preferences->Data->Limit Number of saved quotation...

If all this fails, follow the delete and reinstall route.
 
#3
Amibroker (in trial mode) will not save data.

If your amibroker is not running in trial mode, you've either kept upper limit too low or something very basic is wrong. Does your machine have enough hard-drive space?

Check Tools->Preferences->Data->Limit Number of saved quotation...

If all this fails, follow the delete and reinstall route.
I have full version. it saves database. I have 120gb free on my hard disk.:lol: Upper limit is on max still when I have to feed new data then all d old data get replaced by new data.:mad:
 
#5
If there is no solution to this then it is the most annoying problem of amibroker
 

mastermind007

Well-Known Member
#6
If there is no solution to this then it is the most annoying problem of amibroker
Problem that you are facing is not amibroker problem. Problem is somewhere in your config or on your machine and it cannot be resolved remotely.

Most annoying Amibroker problem is that it keeps making copies of same AFL over and over and over and over again. On one installation, I had seen 440+ copies of Price.afl (with little or no change amongst them).

The drag-drop folder could be, by far the biggest source many of the afl bugs.
 

Iron_Man

Active Member
#7
This happens when the script name is same. Here is what you need to do

First change d script name from NCC to smthing else..like NCC1 etc. Then upload d data to ami. Now u will see NCC nd NCC1. Go to d menu on d top nd use merge option which will merge ur NCC1 with NCC
 
#8
This happens when the script name is same. Here is what you need to do

First change d script name from NCC to smthing else..like NCC1 etc. Then upload d data to ami. Now u will see NCC nd NCC1. Go to d menu on d top nd use merge option which will merge ur NCC1 with NCC
:(

I did this many times but ami dont read the new data e.g NCC1 And in the merge menu it dont show the new file so how can I merge it? [Tried 3 diff version of ami] :mad: Screenshot - 02_04_2015 , 22_36_31.png
 
#9
Problem that you are facing is not amibroker problem. Problem is somewhere in your config or on your machine and it cannot be resolved remotely.

Most annoying Amibroker problem is that it keeps making copies of same AFL over and over and over and over again. On one installation, I had seen 440+ copies of Price.afl (with little or no change amongst them).

The drag-drop folder could be, by far the biggest source many of the afl bugs.
I dont have any prob on my machine,:D well this problem is faced by many user. and what u mean by "config" which settings u r talking about? :(Plz show me some screenshots of that. And also show how you update the data with screenshots :thumb:
 

Raghuveer

Well-Known Member
#10
I have amibroker 5.5 when I have Intraday data for suppose NCC script. from 20.3.2015 to 25.3.2015. Now when I backfill the data from external data feeder software (RT) to amibroker from 26.3.2015 to 30.3.2015 . It dont update it , it replace new data from old data. So data from 20 to 25march had been lost. What to do to keep both data in single database or it updates new data without deleting old data?
I may be way off here...but seeing that so far there is no solution, some thoughts.
=========================================================
1.
If your external data feeder software is the problem then, try some other feeder than the one causing all this headache.

If your terminal is NOW/NEST try http://www.traderji.com/intraday/97637-real-time-data-now-nest-trader-amibroker-fcharts.html
Also see other threads by Josh1 for data feed from other terminals.
=========================================================

2.
If you have spent some time (weeks/months) with Amibroker (any version, any pc) working ok then probably the problem is not some silly mistake.

If however you are totally new to Amibroker and want to rule out some silly mistake as a possible cause then post screen shots of every step (even minor step) in your Amibroker usage. Also post settings, paths, format file(s) used, chart afl, sample data being imported, sample data already in db being overwritten.

=========================================================

Start with a reboot and close all unnecessary programs that are auto started. Delete "broker.master" from your db and then start Amibroker.
 

Similar threads

Broker Special Offers

Intraday Higher Leverage

Save up to 90% in brokerage and get higher leverage for intraday trades.

Name:Phone:
Email:City:
State:
Are you a day trader?