Real Time Data Now / Nest Trader to Amibroker, Fcharts

Autoit is not able to read data table. Try restarting RTD. Have you made changes to data table?
Ok I tried again this morning , And to my wonder it worked. Dnt know what was wrong last time.

Also I was not able to get RTD quotes in Ami (I'm kinda new to ami, but as its pretty fast, i m learning this), then i checked my ini file. I set preserve to No and 0. Then added 2 scrips (Nifty and banknifty futs). Saved ini and it worked. Earlier It was used to delete my scrips as preserve options were YES and 0.

Thanks josh again for this wonderful utility.

Btw, this is off topic but should be solved easily here. Can anybody tell me how do i get data in ami with double floating point ? like right now all i can see is 12049.5 instead of 12049.45

i checked afl of price , it uses %g , what shall i use to get 2 points precision ?

Thanks in advance..
 
Btw, this is off topic but should be solved easily here. Can anybody tell me how do i get data in ami with double floating point ? like right now all i can see is 12049.5 instead of 12049.45

i checked afl of price , it uses %g , what shall i use to get 2 points precision ?

Thanks in advance..
Navigate to Tools>>Preferences>>Misc tab
Adjust the number in 'Decimal places in chart title / tools' as per your requirement. Default is 2.
 
Its default 2 there. But i m getting round value to 1 decimal point still on the chart

I'm using josh1 's utility to feed into Ami
The following applies only for cusomizing chart title, anyways im posting for your info.
These specifications allow us to format the output string accordingly.

%.0f will output a number without decimal places (with rounding if necessary), such as 393
%.1f will output a number with 1 decimal place, such as 392.7
%.2f will output a number with 2 decimal places, such as 392.65

Also right click your chart, press "Axes&Grid" tab and see any format tweak is needed.

Btw, have you checked your source feed, rtd, csv whether data comes in with 2 decimal points or not?
 
The following applies only for cusomizing chart title, anyways im posting for your info.
These specifications allow us to format the output string accordingly.

%.0f will output a number without decimal places (with rounding if necessary), such as 393
%.1f will output a number with 1 decimal place, such as 392.7
%.2f will output a number with 2 decimal places, such as 392.65

Also right click your chart, press "Axes&Grid" tab and see any format tweak is needed.

Btw, have you checked your source feed, rtd, csv whether data comes in with 2 decimal points or not?
Thanks ,

This should do the trick i guess. Will try it tonight.

Sorry for being noob , I'm kinda new to Ami interface. :)
 
hello Josh, Today I checked Kite charts. I must say that it's not bad, rather good .. and if zerodha makes a few relevant changes, it can be as good as amibroker or ninjatrader charts plus advantage of free flow of data. But whatever may be case, weare used to ami, hence same visualisation will be problem. SO many other brokers providing Nest. RTD will be useful always.
Anyway, I am facing an unique problem: despite having 8 GB RAM and a xeon server with Windows 8.1 pro 64 bits installed I continue to get NOT ENOUGH MEMORY error in ami when I start RTD and it runs for a few minute ( I am updating only 4-5 scrips). I checked everything, I have much more than suffiicient memory. I didnt install any dotnet framework as windows 8.1 doesnt need that. I am in a fix what may be triggering this error. I know it has nothing to do with RTD troubleshoot. But any help will be very appreciated.

as important as this post is https://www.traderji.com/community/...rader-to-amibroker-fcharts.97637/post-1389319

you also need to do one more step, flush cache from your database preferences. As a warning take a backup of your database before you do that. that will solve performance/hanging issues with RTD
 
While fetching data for NT,

I want to have bid ask bid qty and ask qty to be fetched in real time.

What changes shall i do in .ini file ?

Scrip2=nse_fo|NIFTY19NOVFUT;NIFTY_F1;LTP;LTT;Volume Traded Today;Open Interest;

this is current , where and what shall i append...?

Thanks in advance.
 
You will have to change code. Writing quotes in multiple files simultaneously will slow down the program. Remind me after 13th for missing files.
Ok I tried again this morning , And to my wonder it worked. Dnt know what was wrong last time.

Also I was not able to get RTD quotes in Ami (I'm kinda new to ami, but as its pretty fast, i m learning this), then i checked my ini file. I set preserve to No and 0. Then added 2 scrips (Nifty and banknifty futs). Saved ini and it worked. Earlier It was used to delete my scrips as preserve options were YES and 0.

Thanks josh again for this wonderful utility.

Btw, this is off topic but should be solved easily here. Can anybody tell me how do i get data in ami with double floating point ? like right now all i can see is 12049.5 instead of 12049.45

i checked afl of price , it uses %g , what shall i use to get 2 points precision ?

Thanks in advance..
i
Hi,
I am also new to ami broker and after several tries still i am not able to fetch RTD from Josh1 :(
Dont know what is missing .... every time i getting error of "trading symbol not found"
attaching the screenshot so that where i am doing wrong can be identified.
please check and help
thanks
trading symbol not found.png
 
While fetching data for NT,

I want to have bid ask bid qty and ask qty to be fetched in real time.

What changes shall i do in .ini file ?

Scrip2=nse_fo|NIFTY19NOVFUT;NIFTY_F1;LTP;LTT;Volume Traded Today;Open Interest;

this is current , where and what shall i append...?

Thanks in advance.
try this

scrip2=nse_fo|NIFTY19NOVFUT;NIFTY-F1;LTP;LTT;Volume Traded Today;Open Interest;;Bid Rate;Ask Rate;Bid Qty;Ask Qty
 

Similar threads

Zerodha – Open Paperless Account

Open online account with Zerodha. Free delivery trading and Max Rs 20 for Intraday, F&O, Currency and Commodity Trading. Intraday High leverage with MIS, CO and BO.

Name:Phone:
Email:City:
State:
Are you a day trader?